【備忘録】jwt-auth が インストールに失敗するとき

Laravel で JWT 認証を実装してくれる jwt-auth

インストールしようとしたら失敗してしまいました。

$ composer require tymon/jwt-auth    
 Using version ^0.5.12 for tymon/jwt-auth
 ./composer.json has been updated
 Running composer update tymon/jwt-auth
 Loading composer repositories with package information
 Updating dependencies
 Your requirements could not be resolved to an installable set of packages.
 Problem 1
     - Root composer.json requires tymon/jwt-auth ^0.5.12 -> satisfiable by tymon/jwt-auth[0.5.12].
     - tymon/jwt-auth 0.5.12 requires illuminate/support ~5.0 -> found illuminate/support[v5.0.0, …, 5.8.x-dev] but these were not loaded, likely because it conflicts with another require.

あれ、 0.5.* 系がインストールされている…?

ということで Packagistを確認。

2021年7月に確認した時点では1.0.2が最新の模様

ということでバージョン指定してインストールしたらいけました。

composer require tymon/jwt-auth:^1.0.2 

でも改めて確認してみたら、2021年2月を最後にメンテナンスされていないですね…。使わない方がいいかも。

参考:

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA